GUIServer v1.1.0.4
#1
[Image: guiserver1101640x480.jpg]

Linux
guiserver_v1103_unix.zip:
http://www.mediafire.com/?1esats6ire6j8su

Windows
guiserver_v1103_win32.zip:
http://www.mediafire.com/?updkk1cqe6t1llp
Qt_win32_runtime.zip
http://www.mediafire.com/?ovndpx264cfcsmv same as v1.1.0.1

Mac OSX
guiserver_v1103_osx.zip:
http://www.mediafire.com/?wcbuuq14uwtuuv8
Qt_OSX_runtime.zip:
http://www.mediafire.com/?mct6eusdbc7zf7t same as v1.1.0.1

Update to v1.1.0.4
Mac:
http://www.mediafire.com/file/8c9hcmmq3b...er.app.zip
Linux:
http://www.mediafire.com/file/pp5i8upecb..._linux.zip
Windows:
http://www.mediafire.com/file/dbztog63l2..._win32.zip

v1.1.0.4 Source Code:
http://www.mediafire.com/?3at4lsltvz31num


Installation instructions

Linux
- Copy the files to your AC installation
- Getting Qt runtime from the repos may be needed

Windows
- Copy the files to your AC installation
- Copy the files from Qt_win32_runtime.zip to your AssautCube\bin_win32

OSX
- Open your AssaultCube.app by showing contents and copy guiserver_v1103_osx.zip
- Open a terminal window and navigate to AssaultCube.app/guiserver_v1103_osx/
- Run guiserverinstall.sh
- Copy the files from Qt_OSX_runtime.zip to \Library\Frameworks\

The Qt dependencies are:
QtCore, QtGui, QtOpenGL and Qt's plugins imageformats/qjpegd4

Update to v1.1.0.4
-The update is just a binary file replacement

-Windows & OS X bins were created with Qt 4.5.3
-The Linux version was created under Qt 4.6.3

**NOTE: GUIServer v1104 does not include the anticheat system
Thanks given by:
#2
Thank you!
Been Waiting a long time for this.
Thanks given by:
#3
You are my hero Toca.
Thanks given by:
#4
Thanx for the update for this great piece of software :) im just waiting for a similar thing that will work over a network, ie on my vps.
Thanks given by:
#5
Qt! <3
Thanks given by:
#6
So I installed it, I believe doing everything right. I am on Mac OSX 10.5.8 build 9L31a.
When running the shell script I used the ./ command, everything seemed to go right.
I opened the launcher, went to run a server, started it, the launcher disappeared, and then it said that GuiServer quit unexpectedly.

Oh yea, I put it right in the assaultcube.app folder, right below "contents" I believe this is where it is supposed to be.
Thanks given by:
#7
I dont understand really.

I have windows, and i downloaded the two links under windows.

Then i downloaded the source code.

Then i put the win32 stuff into the bin_win32 folder.

I Dont know where i put the other stuff though, could you please help me.
Thanks given by:
#8
Gracias amigo!
Thanks given by:
#9
(20 Sep 10, 05:15AM)BrickSquad Wrote: Then i downloaded the source code.
You don't need it. If you did what you wrote, it should already work.
Thanks given by:
#10
I had no problems with 1.0.4 version, but i can't run this one :(. I'm runing on a Win XP SP3
Files are placed correctly. Everybody (users) have full control rights on Ac_guiserver.exe. I change ac_server.exe on my server.bat to ac_guiserver.exe. When i run my server.bat, i can see my commandline arguments, but after that, it closes, and no graphical interface is displayed.
[Image: dibujofvy.jpg]

Edit: Other friend has same problem on Win 7, but he gets an Error 'ac_guiserver.exe has stopped working', and he gets the same message runing as Administrator
Edit2: Same problem on Win vista
Thanks given by:
#11
Same here, unexpected error on Windows 7 64bit. If I have got time I´ll recompile it and try it again.
Thanks given by:
#12
Windows XP SP3, I get "ac_guiserver.exe has encountered a problem and needs to close. We are sorry for the inconvenience."
Yeah, the XP error. Upon further inspection it mentions something about qtopengl4.dll
Thanks given by:
#13
i have same problem gibstick
Thanks given by:
#14
TOCA U R AWESOME!!!! i've been waiting for GUI Server 1.1 :)
Not that im rushing u
*download n' try it out
And i got 2 happy till an error came up

OS: Snow leopard

i did put QT in my Library


* error report
Code:
Process:         ac_guiserver [426]
Path:            /Users/TSOR/Desktop/  AC_1.101/AssaultCube 1.1.01 GUI.app/Contents/gamedata/ac_guiserver.app/Contents/MacOS/ac_guiserver
Identifier:      ac_guiserver
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  ??? [1]

Date/Time:       2010-09-20 22:01:15.238 -0400
OS Version:      Mac OS X 10.6.4 (10F569)
Report Version:  6

Interval Since Last Report:          185529 sec
Crashes Since Last Report:           30
Per-App Crashes Since Last Report:   1

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: QtOpenGL.framework/Versions/4/QtOpenGL
  Referenced from: /Users/TSOR/Desktop/  AC_1.101/AssaultCube 1.1.01 GUI.app/Contents/gamedata/ac_guiserver.app/Contents/MacOS/ac_guiserver
  Reason: image not found

Model: iMac6,1, BootROM IM61.0093.B07, 2 processors, Intel Core 2 Duo, 2.16 GHz, 3 GB, SMC 1.10f3
Graphics: NVIDIA GeForce 7300 GT, NVIDIA GeForce 7300 GT, PCIe, 128 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x87), Broadcom BCM43xx 1.0 (5.10.91.27)
Bluetooth: Version 2.3.3f8, 2 service, 19 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Thanks given by:
#15
woooo hoooo. FINALLY

great job Toca!

Edit: same problem on Windows 7 Ulitmate. i can only see cmd but no gui server
Thanks given by:
#16
didn't knew about some hidden dependencies, sorry :)

-updated for windows

linux & osx may have the same problems ..working on it
Thanks given by:
#17
i still have the same problem with windows
Thanks given by:
#18
(21 Sep 10, 09:15AM)BrickSquad Wrote: i still have the same problem with windows
Now is working good.
Sorry for the newbie question but... Have you downloaded the Qt_win32_runtime.zip again? Be sure you unzip files correctly
Thanks given by:
#19
-OS X update

What about linux, any problems there?
Thanks given by:
#20
wow i forgot to extract lol... thank you gibstick haha

but when the thing pops up, and i hit start it goes away and doesnt come back lol
Thanks given by:
#21
leaks
Thanks given by:
#22
Crashes immediately on Ubuntu Karmic.
libqtcore, libqtgui and libqtopengl all version 4.5.2

program output + stacktrace
debugger output
Thanks given by:
#23
GOOD NEWS!
[Image: screenshot20100921at254.png]

Am the 1st 1, to host GUI?
or 1st 1 on mac?
or Both??
*** TSOR has an idea For GUI

for mini map. lets theres say there's a custom map 1.0.4 and 1.1.
GUI Generate "Mini Map" Image
and how bout Auto Save "Custom Mini Map" image - custom ac Map (same thing if know what i mean)
Example "ac_casa"
gui should delect/check image folder it should not over write unless send map updates it.

if send map: if some 1 send map. gui read and Generate and save "mini map" image

mini map write:
./mapshots/ac_custom_map_name


*** TSOR Calls a Vote: add feature: Generate "Custom Map-Mini map image"

edit: for got type this commend line for GUI

// -Gn // to set 'SysOp' name forever, when you chat, default SysOp name, "SysOp Master"
Thanks given by:
#24
@bullbup, can you point them out? It maybe needed to restructure the code so redundant stuff gets deleted before another is created

@tempest the linux binary was createed with Qt4.6.3, your current Qt files version maybe the problem

@TSOR, for the server to create mapshots it would be needed to have the full rendering engine the ac_client has, so for the moment mapshots need to be taken from ac with the command /mapshot
Thanks given by:
#25
Today Qt 4.7 has been released ;)
Thanks given by:
#26
Tell that to Ubuntu.
Thanks given by:
#27
1.- I don't know where to place mapshots nor minimapicons,I placed them in the AC folder.
2.- I put the .dll files and guiserver file into bin_win32
3.- As soon I try to run the server the guiserver crashes

I'm using vista... and I tried with compatible mode with XP and as Administrator but it seems to keep crashing.
Thanks given by:
#28
[Image: filestruct.jpg]
Thanks given by:
#29
Ok i almost got it working, im just stuck on one thing, i run the gui server and it pops up, but when i click the start button it closes, how do i fix that?

this pops up [Image: guiss.png]

and i click start, then it closes
Thanks given by:
#30
Try using a different Port if ur hosting server already
Thanks given by: