not running on linux mint
Hi everyone, i have linux mint 20 and have uncompressed the folder to my home folder/games/assaultcube

No installation was required. Do i need any repositorys?

I read the wiki and it said i must run the file in the main directory but it opens the terminal and closes it but doesn't start the game.

I'm still new to linux so I'm not sure what to do. I have also tried going to the bin folder and running linux client but it still doesn't run. Any help would be appreciated.

edit: I'm using nvida 470 which is the latest one for mint and it's enabled.
Thanks given by:
ok so i ran this is in terminal and here's the error

/home/blast/GamesLinux/AssaultCube_v1.2.0.2/bin_unix/linux_64_client: /usr/lib/x86_64-linux-gnu/ version `CURL_OPENSSL_3' not found (required by /home/blast/GamesLinux/AssaultCube_v1.2.0.2/bin_unix/linux_64_client)"

I have tried the following linux commands in terminal but still no success
sudo apt-get install --reinstall libcurl3
sudo apt-get install --reinstall libcurl4-openssl-dev
apt install ruby-curb
Thanks given by: