HELP: Custom content textures on server don't download
#1
Hello guys i got a real problem with custom content download on server.

As you know I did a new subway map with custom content (mapmodels, textures, skybox and audio).
check the map topic >> https://forum.cubers.net/thread-9045.html

The Map size packaging is around 8 MB.
All the content are installed inside AC folder:
- in the main install folder ("mydocuments/games/assaultcube")
- and in "Mydocuments/Assaultcube" too.
- The packaging looks complete, i didn't find any missing files.
- Map restriction is respected.

When i'm connected on aCKa server as an admin:
- I type  "/sendmap ac_trome" then "/ctf ac_trome"
- it start a new game and normally player will auto download the custom map content from the server when map is loading.

But here is the problem: My custom files appears like 0KB when that's time to download and it's not downloaded, then people have to play on scratchy untextured map....

I tried to /sendmap again then said to people type /getmap.
Unfortunately still not working. No textures, no skymaps and no custom mapmodels.

Do you know why? What is the problem? I downloaded a lot of custom map on some servers and i never had any  problem. I got all the custom contents.
Inclusive on aCKa server whan i send other custom content, people download the textures with no problem...

Exist any restriction about downloading size or anything like that? Or it's from another point?

Between i searched information in AssaultCube documentation and i didn't find nothing about custom maps downloading on server.

Someone can help me please? I spent 80hours on my map and it's just horrible to can't play it decently. it's boring to send the URL to players in game to download the map correctly...

thank you!
Reply
Thanks given by:
#2
Because most of your custom models and stuff are not present on the packages server which used to be hosted through akimbo.

http://packages.cubers.net/packages/

If you package your models correctly following the same scheme as the link above, I can add your map and models to the server if you'd like.
Reply
Thanks given by:
#3
(08 Apr 20, 05:57PM)(aCKa)Deathstar Wrote: Hello guys i got a real problem with custom content download on server.

As you know I did a new subway map with custom content (mapmodels, textures, skybox and audio).
check the map topic >> https://forum.cubers.net/thread-9045.html

The Map size packaging is around 8 MB.
All the content are installed inside AC folder:
- in the main install folder ("mydocuments/games/assaultcube")
- and in "Mydocuments/Assaultcube" too.
- The packaging looks complete, i didn't find any missing files.
- Map restriction is respected.

When i'm connected on aCKa server as an admin:
- I type  "/sendmap ac_trome" then "/ctf ac_trome"
- it start a new game and normally player will auto download the custom map content from the server when map is loading.

But here is the problem: My custom files appears like 0KB when that's time to download and it's not downloaded, then people have to play on scratchy untextured map....

I tried to /sendmap again then said to people type /getmap.
Unfortunately still not working. No textures, no skymaps and no custom mapmodels.

Do you know why? What is the problem? I downloaded a lot of custom map on some servers and i never had any  problem. I got all the custom contents.
Inclusive on aCKa server whan i send other custom content, people download the textures with no problem...

Exist any restriction about downloading size or anything like that? Or it's from another point?

Between i searched information in AssaultCube documentation and i didn't find nothing about custom maps downloading on server.

Someone can help me please? I spent 80hours on my map and it's just horrible to can't play it decently. it's boring to send the URL to players in game to download the map correctly...

thank you!

Perhaps your textures/models are not in your server's map folder?
Reply
Thanks given by:
#4
(08 Apr 20, 07:10PM)X-Ray_Dog Wrote: Because most of your custom models and stuff are not present on the packages server which used to be hosted through akimbo.

http://packages.cubers.net/packages/

If you package your models correctly following the same scheme as the link above, I can add your map and models to the server if you'd like.
Hey bro' thank for the quick answer!

Yes it's good packaged:

Quote:Assaultcube/Packages/

/maps/ac_trome.cgz
/maps/ac_trome.cfg
/maps/previews/ac_trome.jpg
/textures/deathstar/...
/textures/skymaps/sitters
/models/mapmodels/deathstar/...
/audio/ambience/deathstar/...


I only do serious mapping nowaday, then i always respect the AC packages ;)
anyway you can check the packages if you want, but for me looks everything okay.

But anotherday i downloaded a "minecraft theme map" (i don't think its hosted on akimbo  maps packages) and i received every textures... for incredible it was just the textures from minecraft the layout was good... anyway. samething for a beautiful gemma map who looks like a sserious singleplayer game map...

I tought akimbo was down, this is hosted on the AC official website?

If you can add my new map in this official packages, i will be very proud, thank you so much bro, i will do a lot of new good stuff coming soon for our community ;)

map link again: https://gamebanana.com/maps/208807

ps: Exist a way to download this full map pack from the archive? i see a lot of good old maps

(08 Apr 20, 07:10PM)GameMaker Wrote: Perhaps your textures/models are not in your server's map folder?

hey thanks for answwer!
The server is hosted by [aCKa]Perros I only have admin password, then i can /sendmap.
Looks the real problem is my custom stuff are not hosted on official map pack contents.

thanks again cya
Reply
Thanks given by:
#5
It should work now. One thing though, mapmodels need to be in a zipped folder as well as your map files.

http://packages.cubers.net/packages/mode...deathstar/
http://packages.cubers.net/packages/maps...me.cgz.zip
http://packages.cubers.net/packages/text...s/sitters/

This is just for uploading to this server. Otherwise the map was packaged ok.
Reply
Thanks given by: 1Cap
#6
(09 Apr 20, 07:09PM)X-Ray_Dog Wrote: It should work now. One thing though, mapmodels need to be in a zipped folder as well as your map files.

http://packages.cubers.net/packages/mode...deathstar/
http://packages.cubers.net/packages/maps...me.cgz.zip
http://packages.cubers.net/packages/text...s/sitters/

This is just for uploading to this server. Otherwise the map was packaged ok.
Thank you very much dude for the map update ;)
I didn't know about this mapmodels zip folder. is for the mapack only or for all the custom maps in AC folder?
Reply
Thanks given by: