Mouse glitching?
#1
hey guys, i installed assaultcube just today (reset pc) and i was wondering about this mouse glitch, lemme just post my specs
Windows 10 home (fall update)
CPU: Intel celeron N3050
GPU: intel 1st gen graphics
Mouse: zelotes gaming mouse

heres a video showing the error: https://streamable.com/r5xgd
if anyone could help that would be cool
thanks!
Reply
Thanks given by:
#2
A friend of mine had this issue and I believe I solved it due to windows scaling. When I changed his scaling from 125% back to 100, AC behaved just fine once you set the resolution to match your PC. Try that perhaps?
Reply
Thanks given by:
#3
(03 Nov 17, 05:04AM)X-Ray_Dog Wrote: A friend of mine had this issue and I believe I solved it due to windows scaling. When I changed his scaling from 125% back to 100, AC behaved just fine once you set the resolution to match your PC. Try that perhaps?

my scaling is on 100% (see this screenshot), my normal resolution is on 1600 by 900 (widescreen 16:9)
my assaultcube settings are set to ultra quality but in a windowed 1024 by 768 (see this screenshot)
couldnt be the resolution because i had the same jumping in fullscreen 1600 by 900, maybe i got a corrupt game install or something?
Reply
Thanks given by:
#4
I've actually had something similar happen on two occasions. One time was not on AC, it was on CS 1.0 and it was a roller mouse with a long female hair wrapped in it. I don't think anyone uses a roller mouse anymore, Sooooo....

If it's what I think it is, I believe you're going to feel silly. I did when I screwed with my settings for 20 minutes and finally figured it out.
....Is your touch-pad disabled? I ask because you said it's a fresh install, you may have forgot to disable it?
Reply
Thanks given by:
#5
Another good idea would be to clean your mouse since boomhauer roughly brought it up (whether it's a trackball or laser).
Reply
Thanks given by:
#6
My touchpad is disabled in BIOS, and my mouse doesnt jump around for other tasks like in the video. lemme clean it and then come back.
Reply
Thanks given by:
#7
(04 Nov 17, 07:13AM)D3M0NW0LF Wrote: Another good idea would be to clean your mouse since boomhauer roughly brought it up (whether it's a trackball or laser).

i cleaned my laser mouse (who actually uses trackball's) and i still have the problem
Reply
Thanks given by:
#8
Ok, I thought you would have figured that one out, just checking. Try a different USB port. Another thing could be your mouse-pad. Since it's only happening in-game, update DirectX. I have also seen online people having issues with mouse input with Windows Aero enabled, and software that changes the look of the desktop to resemble older Windows versions: vistaswitcher, windowsblinds. I have personally deleted windowsblinds because it altered my mouse input. If those things aren't the problem, look at this article on the steam community, someone with your exact mouse having the same issues with CS. Something to do with IPS:
https://steamcommunity.com/app/730/discu...056728061/
Reply
Thanks given by:
#9
Maybe 
Control Panel
Mouse Properties
Enhance pointer precision off
Restart
?
Reply
Thanks given by:
#10
It's probably not your mouse thats the problem. Got the same problem myself, started after the latest w10 update. Don't have the problem in any other games than AC.
Reply
Thanks given by:
#11
I have that problem and i don't know how to fix it :/ Same happens with sauerbraten
Reply
Thanks given by:
#12
I have the same problem.
Windows 10 latest updates
Logitech G100s
Only happens in AC. Every other game run without problems.

What I've tried so far:
- Disabled HID compliant-mouse (This seems to be a generic driver Windows 10 uses. I've disabled it since my mouse have proprietary drivers so there is only this active: Logitech HID-compliant Gaming Mouse G90/G100/G100s)
- Checked for dust
- Disabling Mouse Acceleration (in AC, in Windows and in mouse settings)
- Increased mouse dpi up to 2500
- Decreased mouse dpi down to 250
In AC mouse settings:
- Increased & decreased mouse sensitivity
- Increased & decreased mouse acceleration
- Increased & decreased mouse filter (for bad ones)

And every combination of all the above.

The problem persists.
Reply
Thanks given by:
#13
Could anybody with the problem check AC from "experimental" branch: https://github.com/assaultcube/AC/tree/experimental ?

The tutorials for Windows: https://forum.cubers.net/thread-7917.html
Reply
Thanks given by:
#14
I've just tested it, it doesn't happen in 'experimental', seems to be a problem with SDL (getting incorrect LPARAM values from mouse pos from windows perhaps?, at least that was the problem that I had in earlier versions of SDL in a project of mine) since I can see it now uses SDL2.

Still that's not the solution for most of us, since we can't play with the current 1.2.0.2 (buggy) version.

Reply
Thanks given by:
#15
Hi again guys. I solved it just installing the previous compilation of windows 10
Reply
Thanks given by:
#16
That doesn't solve anything. Helps no one but you. Is every person under 20 a narcissist?
Reply
Thanks given by:
#17
Some notices: enabling vsync reduces the problem (but doesn't remove it), because the lower FPS the rarer it appears. And when player holds mouse buttons (at least left, right or middle), then the bug doesn't appear at all.
Reply
Thanks given by:
#18
Enabling vsync doesn't solve it for me nor lowering the fps values (tried down to 30), I tried to hold right mouse button but in my case it still appears.

Current Windows version: 10.0.16299.19
Reply
Thanks given by:
#19
Windows 10 FIX: If you're running windows 10 with the "Fall Creators Update" (Version: 1607 - Build: 14393.1794), you will need to uninstall this update! To uninstall, you need to open (Settings -> Update & Security -> Recovery -> Go Back To a Previous Version Of Windows 10[Get Started]), once clicked, it will start uninstalling updates and go through the update procedure. After all that, it will all be fixed :) But some of your new files like a desktop wallpaper will be deleted because it's recovering all old files. But this will fix the problem :)
Reply
Thanks given by:
#20
It will only fix it if you updated to the "Fall Creators Update". This won't work for example if you downloaded an .iso of Windows 10 that is already updated to the "Fall Creators Update" because there is no history of updates to rollback to. That fix the problem partially but not for all of us.

So, until they don't fix it: https://bugzilla.libsdl.org/show_bug.cgi?id=3931

Maybe it is a good opportunity to release 1.2.0.3 (?) with the only addition of SDL2, officially and give it a massive test.

And if that's not in the interest of developers, they could link us to the repo where the only change was the update to SDL2 for everyone to new to know where to get it and compile their own client.

Thanks.
Reply
Thanks given by:
#21
(14 Nov 17, 08:33PM)TheNihilanth Wrote: Maybe it is a good opportunity to release 1.2.0.3 (?) with the only addition of SDL2, officially and give it a massive test.

Yes, we intend to release hotfix version for Windows 10, with SDL2.
Reply
Thanks given by:
#22
(14 Nov 17, 08:44PM)grenadier Wrote: Yes, we intend to release hotfix version for Windows 10, with SDL2.
Any specific date?
Is there a github repo for that hotfix version you could link us?
If you need help I'll be free for the upcoming holydays :D
Reply
Thanks given by: