Mapmodel Bug
#1
I'm making a map. In this map, I have placed a "Mineshaft Elevator" mapmodel. Whenever I go into AssaultCube and load my map, the elevator is not there. There is also no clip preventing me from moving into its designated space but upon entering edit mode, the "entity marker" is still visible from where I placed it. When I place another elevator in the same place (or roughly in the same place), the first elevator appears all of a sudden. What do?

If it helps to know, this map already has its own .cfg file.
Reply
Thanks given by:
#2
did you by chance move the first elevator to an elevation < 0 (floor level) ?

if it says smth like: "closest ent: mapmodel ( x, x, ~250, x)"; hold "3" and scroll until you see it
Reply
Thanks given by:
#3
Indeed I did

So don't move it off the floor?
Reply
Thanks given by:
#4
you can place it "lower" than the floor by lowering the tile its placed on but the mapmodel itself cant be lower than the tile it is placed on I think
Reply
Thanks given by:
#5
Ah ok. Thanks!!
Reply
Thanks given by:
#6
to move a mapmodel below ground, use a negative elevation in the config file entry (3rd parameter)

mapmodel 3 8 -5 0 makke/mine-shaft_elevator

this offsets all entities using that slot

BTW, you could use the dev client (git master branch), which allows setting those parameters from the menu :)

As long as you don't use new map features like floating-point entity attributes or tilted clips, you can use "savemap9" to create maps, that 1.2.0.2 will still load.
Reply
Thanks given by:
#7
Thanks stef. I have another problem though. I tried just placing an elevator on flat ground and when I save the map and reload it, said elevator still disappears (except for the entity marker). Any ideas?
Reply
Thanks given by:
#8
How did you place it?
Reply
Thanks given by:
#9
by typing /newent mapmodel 202

Is it worth mentioning that when I look at mapmodels in the game menu, some of the texts (including the Mineshaft Elevator) are faded out?

Like so: http://imgur.com/a/GufCR
Reply
Thanks given by:
#10
type /loadallmapmodels and make sure to enable the .cfg save in the editing > skymaps menu
Reply
Thanks given by:
#11
That was sort of a bug: I've changed it, so that adding a new slot from the menu now also activates "automapconfig", which needs to be on, if the map config file should be maintained by AC automatically.

type /automapconfig to activate it manually (only needs to be done once for a map)

PS: be careful, if you have a beautifully handcrafted map config file with lots of ASCII art or license information in the comments. automapconfig embeds the config file into the map file - without any comments.
Reply
Thanks given by:
#12
Thanks for the help, stef. I actually found that the mineshaft elevator was "commented out" in .cfg file. Just moved it to the end of the list and got rid of the slash marks
Reply
Thanks given by:
#13
The point of "automapconfig" is, that you don't have to do that manually :)
Reply
Thanks given by: