Link on Debian buster
#1
Hi,
I am trying to compile AssaultCube_v1.2.0.2 to be able to use it on servers (the Buster version is obsolete).

AssaultCube does compile well but linking fails:
Code:
clang++ -O3 -fomit-frame-pointer -Wall -fsigned-char -o ac_client crypto.o audiomanager.o client.o clientgame.o clients2c.o command.o console.o docs.o editing.o entities.o i18n.o log.o main.o menus.o oggstream.o openal.o packetqueue.o physics.o protocol.o rendercubes.o rendergl.o renderhud.o rendermodel.o renderparticles.o rendertext.o rndmap.o scoreboard.o serverms.o server.o serverbrowser.o shadow.o sound.o soundlocation.o soundscheduler.o stream.o texture.o tools.o water.o weapon.o wizard.o world.o worldio.o worldlight.o worldocull.o worldrender.o zip.o bot/bot.o bot/botmanager.o bot/bot_ai.o bot/bot_util.o bot/bot_waypoint.o bot/ac_bot.o bot/ac_bot_ai.o -L../enet/.libs -lenet -L/usr/lib64 -lX11 `sdl-config --libs` -lSDL_image -lz -lGL -lopenal -lvorbisfile -lcurl
Code:
/usr/bin/ld : ne peut trouver -lSDL_image
Code:
/usr/bin/ld : ne peut trouver -lopenal
Code:
/usr/bin/ld : ne peut trouver -lcurl



I do have the sdl-image, openal and curl libs installed.

Code:
dpkg -l |grep -E -- 'sdl-image|openal|curl'
ii  libcurl3-gnutls:amd64                         7.64.0-4                             amd64        easy-to-use client-side URL transfer library (GnuTLS flavour)
Code:
                           amd64        easy-to-use client-side URL transfer library (OpenSSL flavour)
Code:
ii  libopenal-data                                1:1.19.1-1                           all          Software implementation of the OpenAL audio API (data files)
Code:
ii  libopenal1:amd64                              1:1.19.1-1                           amd64        Software implementation of the OpenAL audio API (shared library)
Code:
ii  libsdl-image1.2:amd64                         1.2.12-10+deb10u1                    amd64        Image loading library for Simple DirectMedia Layer 1.2, libraries
Code:
ii  python3-pycurl                                7.43.0.2-0.1                         amd64        Python bindings to libcurl (Python 3)
(soory for the numbers of code frames, but I pasted only once...)
So, what shall I do ?

Thanks for your help.
Thanks given by:
#2
Code:
sudo apt-get install libsdl1.2-dev libsdl-image1.2-dev zlib1g-dev libogg-dev libvorbis-dev libopenal-dev libcurl4-openssl-dev

And later in source/src/tools.h there should be commented out or removed the following line (58th line):

Code:
static inline float round(float x) { return floor(x + 0.5f); }
Thanks given by: