Subgun MP5 model + team script textures
#1
Another model I made from scratch, it's a classic MP5 in polymer with additional team script textures and a menu model.

[Image: MCR6GPq.jpg]


Team script link:
https://forum.cubers.net/thread-8884.html?

Model download link:
https://mega.nz/#!EIs1jTAR!LJMP8o1fnFgTt...m50lP3wXNA

sidenote: I've added an empty at the muzzle and called it "tag_muzzle", it seems to work unless you're using a team script and decide to equip the subgun twice (then no matter the team you're in your skin gets changed to default, and it apparantely breaks the "tag_muzzle")
Thanks given by:
#2
Once again this is a very decent gun model. I am impressed so far :)

When it comes to your missing muzzleflash, you forgot to add one particular string to your md3.cfg, and that is why it does not appear with the normal gun (FFA).
Code:
md3emit tag_muzzle 10 50 55

I ended up fixing, and repackaging your mod. I have also added a world model for the gun, seeing as it is already low poly enough for it to be a decent one. <3 Encased below in the spoiler is a screenshot in game.

Download it here
Thanks given by:
#3
(21 Aug 18, 10:09PM)D3M0NW0LF Wrote: When it comes to your missing muzzleflash, you forgot to add one particular string to your md3.cfg, and that is why it does not appear with the normal gun (FFA).
Code:
md3emit tag_muzzle 10 50 55

Hi! I can see that you're experienced in AC modelling, so I need you to explain something to me.
How do I know what numbers (i guess coordinates) do I put in there? I'm using blender to create my models and these numbers don't seem to match up with anything. And even if I put an empty called tag_muzzle at the end of the barrel, it changes its coordinates after re-importing. Maybe I should use another 3D tool to make my models?

d3f3nd0g just explained to me on discord that these numbers are just frames in the animation, I checked it and it seems to work (for some reason the game crashed when I tried to shoot after re-equipping my model when I was using just 2 frames, including 0)

btw. What software do you use to edit models in md3 and md2?

And thanks for the effort that you've put into fixing my MP5 model ;)
Thanks given by:
#4
You could always try misfit modeler 3d. I personally use the latest dev build. You can get it here

I also use quake 2 modeler for animating world weapons (so they align to the player's own). It can be obtained here



As far as the tag issue goes, that might be an issue with blender's exporting tool(s)... I am not familiar with blender so I cannot say for sure... Though it is very important you add the tag first BEFORE you start animating. If you do not do this and move the tag after animations have been applied, the tag will default to it's original place inside the animation (or at least, that's how it works in misfit 3d)...

BTW those numbers are nothing more than values to determine the particle, size, and speed when it comes to the md3emit command. When it comes to animations, it's starting frame, how many frames, and speed [ex: md3anim attack 1 9 10].  

Also you are welcome! :D
Thanks given by: