Beta-Test for Mac SVN build
#1
I've gotten a Mac DMG built by Julian "absinth" Mayer which we would like to get some feedback about. You should be competent in adminstering your Mac OS X even when it starts acting up if you really want to try this - I can't guarantee anything about this package ATM. For instance, to compile, absinth had to remove "gettext" as dependency, which may or may not lead to problems down the line - this is why we need courageous beta-testers willing to try it out.
The file is 94 MB in size and
can be got from AC-v1.1-for-Mac-BETA-TEST-package.
OUT OF DATE
Due to protocol changes - download only good for local/singleplayer testing
Please await the upcoming beta-release

Please leave some feedback here if you do test it out.
And .. be sure to read all those posts before trying it out yourself to find out wether to expect any trouble with this package.
Thanks given by:
#2
I'll try it out soon on my macbook, and by soon, I will try to get to it in a few hours. I've been looking forward to using it on my Mac for a long time. Thank you very much flowtron.
Thanks given by:
#3
I just downloaded it, I had one major problem and that is I couldn't get to actually play.
I couldn't get past this part:
[Image: AssaultCube_1.png]

I click play and then nothing happens / nothing opens up.
Thanks given by:
#4
I'll check it out later on this day, now i need to study... :(
Here the same prob, after clicking on the play button he tries to load the game, but there are some files / libraries missing...

Code:
Dyld Error Message:
  Library not loaded: @executable_path/../Frameworks/SDL_ttf.framework/Versions/A/SDL_ttf
  Referenced from: /Users/Mathias/Downloads/assaultcube-1/AssaultCube.app/Contents/gamedata/assaultcube.app/Contents/MacOS/assaultcube
  Reason: image not found
Thanks given by:
#5
That looks bad - they only really pertinent stuff I could find right now was this:

Could you please run this "on your binary" - means replace $BINARY with what it says under "Referenced from".
Code:
otool -L $BINARY
Another thread I found mentioned some missing X11 packages/libraries - could you look for some TTF (true-type-font) packages that might be required, please?! The output of otool should help there, it seems like the pendant to ldd on linux - it should list the library dependencies of the binary.
otool man-page

Also absinth said his disabling gettext had something to do with it's a pain to build a version that will be compatible back to 10.4, so I'm guessing you need to have a higher version of Mac OS X. Sorry for not mentioning this earlier - what is the current version of Mac OS X and what would seem to be the most widespread in use inside the AC community at this time?
Thanks given by:
#6
Leopard
Thanks given by:
#7
1. I wll check it later on my SnowLeopard 10.6.4
2. The only useful Mac OS X versions which should be supported are Leopard (10.5) and Snowleopard (10.6) IMO
Thanks given by:
#8
I'm usign 10.6.3 now, and i think you should support it from Leopard (10.5) up to Snow (10.6)
Eventually Tiger (10.4)

Do you need to have X11 to run 1.1?
Thanks given by:
#9
I'm using Snow Leopard. I'll try it later on, after work.
Thanks given by:
#10
The D/L has been updated. absinth has added the TTF as dependency now.
Sorry for the trouble and double-download of 100 MB - and thank you all for testing and reporting.
Just use the same old link in the first posting.
Thanks given by:
#11
thx flow and absinth
I hope we get a static member to the dev team, which uses mac os all the time, the current situation is not the best for mac users
(there is also no win dev)
Thanks given by:
#12
wow i have to say this version is a lot more fun. Im really glad that there's a new gun and the HUD looks really nice. Good job! One question though: is this going to be the new version or is it just a mod?
Thanks given by:
#13
This is the new version and will be 1.1.0 :P
Thanks given by:
#14
I <3 it :) Now to find some people to go online with :)
Thanks given by:
#15
Testing now :D
I'll give some feedback once I'm done messing around.
Thanks given by:
#16
(21 Jun 10, 03:31PM)MathiasB Wrote: Do you need to have X11 to run 1.1?

Every Mac OS from Leopard onward (maybe even tiger onward) has X11

I just tried it out. One thing I noticed is that when crouching the player model seems too big sometimes. I shot Dreamer in shine like 3 feet above his head and it registered a hit, then the next time i did it, no damage occurred. Maybe just somethiung thats always been there or an error. Just sayin.

edit:

While I really like the new spectate mode, I dislike greatly that when you connect to a server you automatically are set to spectate mode. Couldn't you go straight to playing, then change to spectate mode if you want? Could this be an option for server owners so that it only happens with match servers? It's really annoying IMO.
Thanks given by:
#17
I have a problem. When I open the beta it kinda mixes with the 1.0.4 version and the HUD icons look weird, the mods I had for 1.0.4 are there, the carbine isn't there, and the sounds are all messed up. When I suicide the grenade sound comes, when I shoot with smg the nade bouncing sounds, when I jump it sounds like a drain. IDK, help?

EDIT: Actually, the 1.0.4 is experiencing this. I discovered how to play the beta but getting the beta destroyed the old one :/ Help plz?
Thanks given by:
#18
I had a similar experience, I think. After playing 1.1, the very next time I open up 1.0.4, I get a whole list of unknown commands in the console.

[Image: screenshot20100621at841.png]

However, each subsequent time I open up 1.0.4, there are no unknown commands. Its only in the first time I open it up after using 1.1. Not really a problem, or a big deal, I just didn't know if this would point you in the direction of a bug or something.
Thanks given by:
#19
I think the problem is that 1.0.4 gets confused and used 1.1's data :/
How can I fix 1.0.4? Re download and install?
Thanks given by:
#20
(21 Jun 10, 11:25PM)ViperX07 Wrote:
(21 Jun 10, 03:31PM)MathiasB Wrote: Do you need to have X11 to run 1.1?

Every Mac OS from Leopard onward (maybe even tiger onward) has X11

I don't have that piece of shit running...
It sucks, i use it never, so I don't install it.

But is it really needed for 1.1?
Thanks given by:
#21
I don't think so. Not from what I have seen. I also have the data share thing. My 1.0.4 will carry over info to the 1.1 and vice versa. It's like they can communicate. Devs, is there a possible robot rebellion happening?
(21 Jun 10, 10:04PM)Dreamer Wrote: I <3 it :) Now to find some people to go online with :)

CarbineKing and the carBONATOR

:P
Thanks given by:
#22
x11 is stock with mac os...wow?

i ran it on the lastest version of mac os, snow lep... works fine.
though it feels slower loading up and maps and all..dunno
Thanks given by:
#23
Sorry about mentioning X11 - it was just part of the thread I found, it doesn't pertain to AC in any way.

Regarding all you people with issues - this is exactly why I tried to warn you before downloading - you need to be in command of your system if you're willing to try beta stuff!
It may be a simple issue of adapting the HOME variable - AFAIK the Mac-Launcher has some fields where you can pass options - add something like "--home=/path/to/AC-1.1b-user-data" to the run-parameters.
You might want to check the menu-item "open user directory" to check out this actually is the issue - if they both point to the same directory then you should move that to somewhere else (as backup) and (re)create seperate directories for each instance of AC - they can be empty to begin with, but will fill with shadow.dat files on first run and config/saved.cfg-and-friends on first quit. Keep your downloaded maps, scripts and models in there!

Could someone actually familiar with all of these settings as they work/appear in the Mac-World please elaborate on the correct naming, phrasing and methodry required!?!
Thanks given by:
#24
gah can someone help me on something? Every time I download the beta it mixes with the 1.0.4 old version and I have to delete all the files and download 1.0.4 again. It uses the same directory for some reason, unfortunately :/
Thanks given by:
#25
as flowtron already said, you should change the home path (the place where you´re settings are saved) different
Thanks given by:
#26
And how would I do that?
Thanks given by:
#27
as he already said, in the ac launcher add something like "--home=/path/to/AC-1.1b-user-data"
Thanks given by:
#28
Is there an estimate for when the package for windows will be ready?
Thanks given by:
#29
Lol I don't understand that. I'll just lay off beta.
Thanks given by:
#30
LaNterN, Windows and Linux user just can use this link (for an always up to date version):
http://actiongame.svn.sourceforge.net/vi.../?view=tar
Thanks given by: