Can't claim admin on 1.1.0.3 (linux) server?
#1
Hi,
I recently upgraded my server to 1.1.0.3 from 1.1.0.1 . Everything went fine, but once i restarted it (with the same commandline), i no longer can claim admin on the server when i log in. Instead, I just get kicked. The same thing has happened with everybody else who has tried, so it most likely isnt a client error. The server runs Ubuntu 10.04 and i compiled ac from the source tarball using the instructions on the wiki. I know it reads the passwords in the serverpwd.cfg file because it logs this:
Code:
Oct 12 17:28:56 reading admin passwords 'config/serverpwd.cfg'
Oct 12 17:28:56 line   9: pas***** 0
Oct 12 17:28:56 read 1 admin passwords from 'config/serverpwd.cfg'
yet when i go and type in /setadmin 1 password i am kicked. Server commandline is http://pastebin.com/yqVLAK08

any clue or fixes?
Thanks given by:
#2
You tried calming admin from the multiplayer menu?

Oh and don't do /setadmin 1 because someone might get your pass someday for themselves to use XD

Other than that idk :\

Maybe reset your pass?
Thanks given by:
#3
yea multiplayer menu makes no difference. and how would /setadmin 1 let someone else see your password?
Thanks given by:
#4
i think if you forgot to write the / then your done cuz they can read the pass
Thanks given by:
#5
Think of it this way... what if you forgot the / and only did setadmin 1 *********
lol looks funny XD and gives your pass out to whoever remembers it XD
last but not least, it makes you look like you failed XD
Thanks given by:
#6
ash, speaking english usually helps a lot. lol.

iguana, thats why we have the ability to change the password. :D

anybody have any real help?
Thanks given by:
#7
there a guy in pro who did that and i got the pass LOL!
but they chaged the pass
Thanks given by:
#8
I've got the same problem with the GUIserver, are you using it? Try the normal server... it'll work
Thanks given by:
#9
im using the server_wizard.sh
Thanks given by:
#10
BUMP :P
Thanks given by:
#11
bump?

Oh I think I figured it out...
Destroy your server and start over again XD
Thanks given by:
#12
LOL uh... will try?
Thanks given by: